Search
 
 

Display results as :
 


Rechercher Advanced Search

Latest topics
Shopmotion


Navigation
 Portal
 Index
 Memberlist
 Profile
 FAQ
 Search
Affiliates
free forum
 
April 2018
MonTueWedThuFriSatSun
      1
2345678
9101112131415
16171819202122
23242526272829
30      

Calendar Calendar


XY Tolerance appears out of control when opening 9.1 mxd's in 9.2

Go down

XY Tolerance appears out of control when opening 9.1 mxd's in 9.2

Post  John Par on Sun Mar 16, 2008 9:24 am

Hello All

I've just upgraded to ArcView 9.2 and now seem unable to edit below 2m resolution when working in mxd's saved in version 9.1 - if this is attempted the vertices become generalised, totally distorting the feature. This happens for both existing as well as newly created features, and has been a problem with all mxd's opened so far.

I've seen that this clustering of points is a default setting in 9.2 and there's no way to turn it off. However, the feature class XY Tolerance settings reports in ArcCatalogue to be very small (0.000016000000015 meters) and so shouldn't be affecting points a couple of meters apart. I've tried reducing the tolerance further with the Upgrade Spatial Reference wizard, and also tried setting them low in the Application Environment settings, to no avail.

Although I've not used the topology functions in the past I also looked here and oddly enough this wouldn't let me set the tolerance below 2m, reporting this wasn't allowed by the feature class spatial reference.

Has anyone got any idea what might be going on here or have any idea what else could be having this effect?

Thanks!

John Parsons

John Par
Guest


Back to top Go down

Re: XY Tolerance appears out of control when opening 9.1 mxd's in 9.2

Post  pete wil on Sun Mar 16, 2008 9:25 am

has there been any update/new on this issue? we have a mixed (9.1, 9.2) environment and are running into some problems with geoprocessing (intersect specifically). there seems to be some kind of generalization going on and i'm guessing it has to do with the "tolerance". i too have tried multiple descreasing settings for it (N.B. can't use 0 or it'll be automatically calced). we really don't have time or resources to do R&D on software that used to work without problems.

pete wil
Guest


Back to top Go down

Re: XY Tolerance appears out of control when opening 9.1 mxd's in 9.2

Post  Doug Mor on Sun Mar 16, 2008 9:26 am

John-

Although you didn't mention it specifically I assume these edits work properly if you create a new map and edit your feature class there.

The map itself has a spatial reference (and thus it's own XY tolerance). I'd suggest going through the layer properties -> coordinate system tab and select the layer in the list that you are seeing problems with. Selecting this layer and committing those changes should change the map's spatial reference to match that of the dataset you selected. Once you've done this try your edits again.

Doug Mor
Guest


Back to top Go down

Re: XY Tolerance appears out of control when opening 9.1 mxd's in 9.2

Post  Tim Gibb on Sun Mar 16, 2008 9:27 am

Well, its been nearly a year since this problem was reported and it doesn't appear to have been addressed. Doug, you suggested "going through the Layer Properties-> coordinate system tab and select the layer in the list that you are seeing problems with", well there is no such tab in the Layer Properties tab. There is such a tab in the Data Frame Properties, but there is no way what so ever to adjust any spatial tolerances.

Having combed the knowledge base, the best that I have come up with it that this problem has its roots in the introduction of the "XY tolerance" in version 9.2. I have found only a single location where one is able to adjust this (Editor Toolbar>More Editing Tools>Topology>Map Topology> Cluster Tolerance), but it will not adjust beyond that which is already set by ArcMap for the feature class. I have tried to change the tolerances using the command line interface (XYTolerance command), but this has had little effect on the generalization.

Now, lets wrap our heads around this problem and get it to work before we are forced to scrap our v9.2 installations and go back to 9.1!

Tim Gibb
Guest


Back to top Go down

Re: XY Tolerance appears out of control when opening 9.1 mxd's in 9.2

Post  Melita K on Sun Mar 16, 2008 9:28 am

Doug did mean data frame properties > coordinate system tab, layers (lower left box), and set the data frame's coordinate system explicitly to the layer you're editing. Not only is the coordinate system changed, but also the data frame's tolerance, resolution, and domain values.

Melita

Melita K
Guest


Back to top Go down

Re: XY Tolerance appears out of control when opening 9.1 mxd's in 9.2

Post  pete wil on Sun Mar 16, 2008 9:28 am

all of my data is in the same coordinate system so that's not part of the issue for me.
i think there might be something with the change to the "high precision" geodb at 9.2. unfortunately there is no way to create a "low precision" one in 9.2. so i found an old 9.1 low precision personal gdb, deleted the fc's, and saved it so i have a 9.2 low precision mdb. whenever i need to create new fc's i just do an OS copy paste to a new mdb file and start working.

pete wil
Guest


Back to top Go down

Re: XY Tolerance appears out of control when opening 9.1 mxd's in 9.2

Post  Doug Mor on Sun Mar 16, 2008 9:29 am

Pete-

It is important to realize that it is not just the coordinate system that is stored in the map, but the spatial domain and tolerances. This information may not be the same as that defined in your data.

Doug Mor
Guest


Back to top Go down

Re: XY Tolerance appears out of control when opening 9.1 mxd's in 9.2

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum